Multiple Payers - TRULI HEALTH, FLORIDA BLUE, FLORIDA BLUE MEDICARE - ALL - All Florida Blue, Florida Blue Medicare, and Truli for Health transactions will be unavailable April 17, 2026 from 7PM until April 20, 2026; 6AM due to a scheduled outage. We a...

Scheduled for Apr 10, 12:40 EDT  -  Apr 20, 06:00 EDT

Update

Customers are receiving errors
Next Steps and ETA for resolution:
Availity continues to monitor for resolution.
Posted Apr 10, 2026 - 12:40 EDT

Update

Customers are receiving errors
Next Steps and ETA for resolution:
Availity continues to monitor for resolution.
Posted Apr 10, 2026 - 12:38 EDT

Scheduled

Customers are receiving errors
Next Steps and ETA for resolution:
Availity continues to monitor for resolution.
Posted Apr 10, 2026 - 12:37 EDT
This scheduled maintenance affects: FLORIDA BLUE, TRULI HEALTH, and FLORIDA BLUE MEDICARE.