Multiple Payers - MOLINA HEALTHCARE SOUTH CAROLINA, MOLINA HEALTHCARE WASHINGTON, MOLINA HEALTHCARE IOWA, MOLINA HEALTHCARE MICHIGAN, MOLINA HEALTHCARE TEXAS, MOLINA HEALTHCARE IDAHO, MOLINA HEALTHCARE UTAH, MOLINA HEALTHCARE CALIFORNIA, MOLINA ILLINOI...

Incident Report for Payer Notifications

Resolved

This incident has been resolved.
Posted Nov 08, 2025 - 06:04 EST

Update

We are seeing Claim Status Inquiry transactions failing with timeout errors.
Customers are receiving timeout errors.
Next Steps and ETA for resolution:
We have reached out to the payer to report this issue. We will continue to monitor and send updates as available.
Availity continues to monitor for resolution.
Posted Nov 07, 2025 - 10:44 EST

Update

We are seeing Claim Status Inquiry transactions failing with timeout errors.
Customers are receiving timeout errors.
Next Steps and ETA for resolution:
We have reached out to the payer to report this issue. We will continue to monitor and send updates as available.
Availity continues to monitor for resolution.
Posted Nov 07, 2025 - 10:32 EST

Identified

We are seeing Claim Status Inquiry transactions failing with timeout errors.
Customers are receiving timeout errors.
Next Steps and ETA for resolution:
We have reached out to the payer to report this issue. We will continue to monitor and send updates as available.
Availity continues to monitor for resolution.
Posted Nov 07, 2025 - 09:28 EST
This incident affected: MOLINA HEALTHCARE TEXAS, MOLINA HEALTHCARE CALIFORNIA, MOLINA HEALTHCARE MISSISSIPPI, MOLINA HEALTHCARE WASHINGTON, MOLINA HEALTHCARE MICHIGAN, PASSPORT HEALTH PLAN BY MOLINA HEALTHCARE, MOLINA HEALTHCARE IDAHO, MOLINA HEALTHCARE FLORIDA, MOLINA HEALTHCARE NEW YORK (TOTAL CARE NEW YORK), MOLINA HEALTHCARE SOUTH CAROLINA, MOLINA HEALTHCARE UTAH, MOLINA ILLINOIS, MOLINA HEALTHCARE WISCONSIN, and MOLINA HEALTHCARE IOWA.