BCBSND - Claim Status Inquiry - The BCBSND direct messaging feature is currently unavailable. Check both Claim Status and Remittance Viewer on Availity, for providers with additional questions contact BCBSND. We apologize for any inconvenience. This me...

Incident Report for Payer Notifications

Resolved

This incident has been resolved.
Posted Oct 24, 2025 - 10:15 EDT

Update

Customers are receiving errors
Next Steps and ETA for resolution:
Availity continues to monitor for resolution.
Posted Oct 23, 2025 - 10:39 EDT

Identified

Customers are receiving errors
Next Steps and ETA for resolution:
Availity continues to monitor for resolution.
Posted Oct 23, 2025 - 09:58 EDT
This incident affected: BCBSND.