HUMANA - Multiple Transactions - Due to scheduled maintenance HCSR Detailed Auth/Referral, HCSR Inpatient Auth, HCSR Outpatient Auth, HCSR Real Time Authorization and HCSR Referral transactions will be unavailable Friday, March 6th from 10:00:00 PM EST...

Scheduled for Mar 6, 22:00 EST  -  Mar 7, 09:30 EST

Update

We are seeing HCSR Detailed Auth/Referral, HCSR Inpatient Auth, HCSR Outpatient Auth, HCSR Real Time Authorization and HCSR Referral transactions failing with errors.
Customers are receiving errors
Next Steps and ETA for resolution:
Availity continues to monitor for resolution.
Posted Mar 02, 2026 - 17:44 EST

Scheduled

We are seeing HCSR Detailed Auth/Referral, HCSR Inpatient Auth, HCSR Outpatient Auth, HCSR Real Time Authorization and HCSR Referral transactions failing with errors.
Customers are receiving errors
Next Steps and ETA for resolution:
Availity continues to monitor for resolution.
Posted Mar 02, 2026 - 17:43 EST
This scheduled maintenance affects: HUMANA.