SHAREDHEALTHMISSISSIPPI - 270 - BCBST will be performing maintenance of services that may impact Eligibility and Benefits inquiries beginning at 9PM on 5/29 until 7AM on 5/30. If you receive an error with your Eligibility and Benefits transaction, plea...

Scheduled for May 26, 12:30 EDT  -  May 29, 07:00 EDT

Update

Customers are receiving errors
Next Steps and ETA for resolution:
Availity continues to monitor for resolution.
Posted May 26, 2026 - 12:24 EDT

Scheduled

Customers are receiving errors
Next Steps and ETA for resolution:
Availity continues to monitor for resolution.
Posted May 26, 2026 - 12:22 EDT
This scheduled maintenance affects: SHAREDHEALTHMISSISSIPPI.