CARESOURCE - Multiple Transactions - Due to scheduled maintenance Eligibility and Benefits Inquiry and Claim Status Inquiry transactions will be unavailable Thursday, November 13th from 5:00:00 PM EST through 7:00:00 AM EST Friday, November 14th.

Scheduled for Nov 13, 2025, 20:30 EST  -  Nov 14, 2025, 07:00 EST

Update

We are seeing Eligibility and Benefits Inquiry and Claim Status Inquiry transactions failing with errors.
Customers are receiving errors
Next Steps and ETA for resolution:
Availity continues to monitor for resolution.
Posted Nov 13, 2025 - 20:23 EST

Scheduled

We are seeing Eligibility and Benefits Inquiry and Claim Status Inquiry transactions failing with errors.
Customers are receiving errors
Next Steps and ETA for resolution:
Availity continues to monitor for resolution.
Posted Nov 13, 2025 - 20:22 EST
This scheduled maintenance affects: HUMANA-CARESOURCE, CARESOURCE OF OHIO, CARESOURCE OF INDIANA, CARESOURCE OF WEST VIRGINIA, and CARESOURCE OF GEORGIA.