PARKLAND COMMUNITY HEALTH PLAN - Claim Status Inquiry - For additional assistance, please contact PCHP Provider Services at 1-888-672-2277

Incident Report for Payer Notifications

Update

Customers are receiving errors
Next Steps and ETA for resolution:
Availity continues to monitor for resolution.
Posted Jul 17, 2026 - 10:57 EDT

Identified

Customers are receiving errors
Next Steps and ETA for resolution:
Availity continues to monitor for resolution.
Posted May 15, 2026 - 10:25 EDT
This incident affects: PARKLAND COMMUNITY HEALTH PLAN.