HEALTH SERVICES FOR CHIILDREN WITH SPECIAL NEEDS - 2 - Notice to Providers: Currently the Claims Status Lookup is available for a single date. Thank you for your patience.

Incident Report for Payer Notifications

Resolved

This incident has been resolved.
Posted Mar 05, 2026 - 12:39 EST

Update

We are seeing Claim Status Inquiry transactions failing with errors.
Customers are receiving errors
Next Steps and ETA for resolution:
Availity continues to monitor for resolution.
Posted Oct 10, 2025 - 12:35 EDT

Update

We are seeing Claim Status Inquiry transactions failing with errors.
Customers are receiving errors
Next Steps and ETA for resolution:
Availity continues to monitor for resolution.
Posted Oct 10, 2025 - 12:21 EDT

Monitoring

We are seeing all transactions failing with errors.
Customers are receiving errors
Next Steps and ETA for resolution:
Availity continues to monitor for resolution.
Posted Oct 10, 2025 - 12:19 EDT
This incident affected: HEALTH SERVICES FOR CHIILDREN WITH SPECIAL NEEDS.