MAGELLAN HEALTH - Multiple Transactions - Due to scheduled maintenance Eligibility and Benefits Inquiry and Claim Status Inquiry transactions will be unavailable Sunday, December 21st from 7:00:00 AM EST through 1:00:00 PM EST Sunday, December 21st.

Scheduled for Dec 21, 2025, 07:00 - 13:00 EST

Update

Scheduled downtime to complete hardware and/or OS updates as needed.
Posted Dec 01, 2025 - 16:28 EST

Update

We will be undergoing scheduled maintenance during this time.
Posted Dec 01, 2025 - 16:23 EST

Scheduled

Scheduled downtime to complete hardware and/or OS updates as needed.
Posted Dec 21, 2025 - 07:00 EST
This scheduled maintenance affects: MAGELLAN HEALTH.