REGENCE - ALL - Due to system maintenance, member benefit booklets, ID cards, and Provider Reports are not available between 7:30 PM and 10:30 PM.

Scheduled for Feb 11, 22:00 EST  -  Feb 12, 02:00 EST

Update

Customers are receiving errors
Next Steps and ETA for resolution:
Availity continues to monitor for resolution.
Posted Feb 06, 2026 - 17:05 EST

Scheduled

Customers are receiving errors
Next Steps and ETA for resolution:
Availity continues to monitor for resolution.
Posted Feb 05, 2026 - 19:17 EST
This scheduled maintenance affects: REGENCE BLUESHIELD OF IDAHO, REGENCE BCBS OF OREGON, REGENCE BLUESHIELD, REGENCE BCBS OF UTAH, BRIDGESPAN HEALTH COMPANY, and ASURIS NORTHWEST HEALTH.