CAREFIRST BLUECROSS BLUESHIELD -270 - Eligibility and Benefits Inquiry transactions are currently unavailable.

Incident Report for Payer Notifications

Resolved

This incident has been resolved.
Posted Oct 22, 2025 - 15:56 EDT

Monitoring

Due to scheduled maintenance Eligibility and Benefits Inquiry, Claim Status Inquiry and Health Care Services Inquiry transactions will be unavailable Sunday, August 24th from 12:00:00 AM EDT through 4:00:00 AM EDT Sunday, August 24th.
Posted Aug 23, 2025 - 21:24 EDT