Multiple Payers - CORPORATE BENEFIT SERVICES OF AMERICA (CBSA), 60054, AETNA, BANNER HEALTH, ALLINA HEALTH, MTAIN - 270 - Eligibility and Benefits Inquiry transactions are currently unavailable.

Incident Report for Payer Notifications

Resolved

This incident has been resolved.
Posted Sep 01, 2026 - 13:56 EDT

Identified

We are seeing Eligibility and Benefits Inquiry transactions failing with Timeout/Invalid Response Received errors.
Posted Sep 01, 2026 - 08:28 EDT
This incident affected: 60054 and AETNA.