FLORIDA BLUE - ALL - All Florida Blue, Florida Blue Medicare, and Truli for Health transactions will be unavailable March 22nd, 2026 from 7PM until March 23, 2026 6AM due to an unscheduled outage. We apologize for any inconvenience.

Scheduled for Mar 5, 16:58 EST  -  Mar 23, 06:00 EDT

Update

Customers are receiving errors
Next Steps and ETA for resolution:
Availity continues to monitor for resolution.
Posted Mar 05, 2026 - 16:54 EST

Update

Customers are receiving errors
Next Steps and ETA for resolution:
Availity continues to monitor for resolution.
Posted Mar 05, 2026 - 16:51 EST

Update

Customers are receiving errors
Next Steps and ETA for resolution:
Availity continues to monitor for resolution.
Posted Mar 05, 2026 - 16:15 EST

Update

Customers are receiving errors
Next Steps and ETA for resolution:
Availity continues to monitor for resolution.
Posted Mar 05, 2026 - 16:14 EST

Scheduled

Customers are receiving errors
Next Steps and ETA for resolution:
Availity continues to monitor for resolution.
Posted Mar 05, 2026 - 16:12 EST
This scheduled maintenance affects: FLORIDA BLUE.