Multiple Payers - HUMANA, HUMANA, HUMANA HEALTHY HORIZON OH MEDICAID, HUMANA LONG TERM CARE, HUMANA HMO, HUMANA HMO, CompBenefits, Humana Dental Non Claims - Multiple Transactions - Eligibility and Benefits Inquiry, Claim Status Inquiry, Health Care Se...

Incident Report for Payer Notifications

Resolved

This incident has been resolved.
Posted Apr 22, 2026 - 03:51 EDT

Identified

We are seeing Eligibility and Benefits Inquiry, Claim Status Inquiry, Health Care Services Inquiry, HCSR Outpatient Auth, HCSR Detailed Auth/Referral and HCSR Inpatient Auth transactions failing with timeout/timeout errors.
Customers are receiving timeout/timeout errors.
Next Steps and ETA for resolution:
We have reached out to the payer to report this issue. We will continue to monitor and send updates as available.
Availity continues to monitor for resolution.
Posted Apr 22, 2026 - 02:56 EDT
This incident affected: HUMANA LONG TERM CARE, HUMANA, CompBenefits, and HUMANA HMO.